Issue with Rift

Jan 11, 2014 at 7:12 PM
Edited Jan 11, 2014 at 7:12 PM
Hello,

so I've been trying to use the Oculus Rift support in the client, and it seems to work OK up to the point where I need to switch to 3D mode, and everything just goes black.. It looks like it's trying to work, but its not actually rendering anything until I exit 3D mode again.

My display is cloned to both my primary display and the rift. I can see through the rift when I'm not in 3D mode, but obviously it doesn't look proper.


My Rig:
Sapphire R9 280x 3GB video card (latest drivers installed)
Intel i5 4670K
16GB 1600MHz memory
Samsung 256GB 840 Pro
Windows 7 Home Premium 64bit

I also tried updating the firmware on my rift to the latest one to see if that makes a difference.

Not sure what I'm doing wrong or how to get it to work.
Coordinator
Jan 12, 2014 at 8:02 PM
Hi Kyler,

It sounds like you need to turn Basic Shaders on in the viewer preferences: Avatar menu > Preferences > Graphics section > General tab and tick the box for "Basic shaders".

If this doesn't work, let me know.
Jan 12, 2014 at 8:28 PM
So the basic shaders were grayed out on my graphics window, but at least that led me to the fix.

So after figuring out that basic shaders were required for this to work, I found that if basic shaders were grayed out it was because it doesn't think that the video card is supported. So after checking the gpu_table.txt file that you include in your version, it was missing my ATI Radeon R9 video card. I grabbed the latest one from the last Firestorm build and stuck it into the ctrl alt studio viewer folder and relaunched the client, and voila, the basic shaders option was available, and once checked, everything started working perfectly!

Thanks for the help!!!
Coordinator
Jan 13, 2014 at 3:31 AM
Ah, yes, there's a GPU table update that will be included in the next alpha.

Great you got it working!