Advanced Lighting Model requirement

Mar 16, 2015 at 2:16 PM
Dear David,

As stated in the release notes of the viewer I found out that Advanced Lighting Model needs to be turned on in the viewer for the Oculus Rift to function. When it is turned off, all I get is a flickering screen when entering into Rift mode.

Is there a specific reason why Advanced Lighting Model needs to be turned on at this moment? I am asking this because I noticed that the OR project viewer of Linden Labs does work without Advanced Lighting Model or shaders turned on and this can give a noticable boost in performance on for example lower end systems.

Thanks in advance for your support.

Kind Regards,

Arjan Strijland
Coordinator
Mar 17, 2015 at 4:27 AM
Hi Arjan,

I had a good go at getting Riftlook working without Advanced Light Model a while ago with Rift SDK 0.4.4 but I couldn't bend the graphics pipeline code to comply. I should perhaps have another go but I don't have very much spare time to work on this project. Updating to the current version of Firestorm code is next on my list.

David
Mar 17, 2015 at 3:20 PM
Dear David,

Would you maybe mind explaining me what you have tried so far?
As for the specific reason of my question. We are trying to integrate the Oculus Rift into our remote virtual training program to analyze if the Oculus Rift can deliver a better training experience. Unfortunatly I find that maintaining a constant frame rate of around 60 or even better 75 is not that easy in OpenSim. I'm afraid this frame rate issue can limit user/training experience quite a bit.
This is with a fairly high end system which we prefer not to add to the requirements of using our training program:)

My thought was that if I could switch the Advanced Lighting Model off, it could give a needed boost in performance on some lower end systems like laptops and older systems. So if you could give me a hint in the right direction I could try giving it a shot myself.

Except for the Advanced Lighting Model, do you maybe have other suggestions for making improvements to the Rift view performance wise?

Many thanks in advance.

Arjan Strijland
Coordinator
Mar 18, 2015 at 1:33 AM
Hi Arjan,

To improve frame rates, in Preferences > Graphics > General:
  • Turn shadows off
  • Reduce your draw distance
For other suggestions see the items under "Further Rift tips" in the release notes, http://ctrlaltstudio.com/viewer/releases/1-2-3-42796-alpha .

In particular, if you're not achieving 75 FPS reasonably consistently then you should probably configure your Rift display to 60Hz.

While some of the suggestions may not improve frame rates per se, they may improve the perceived experience (e.g., reduce judder while turning).


Regarding rendering without Advanced Lighting Model turned on, the difficulty I encountered was getting the basic shader output to render to a frame buffer object suitable for the Rift SDK to do its barrel distortion on.

David